Hello, I am using an Oculus 2 and am having issues taking photos in Passthrough mode. When I take photos in Passthrough mode the existing elements in the room (from passthrough) do not show up on the camera screen or in the photos that were taken. I looked to see if there were other setting, but I did not see anything. Is there a setting that I am missing in Arkio or is it something that I need to adjust with the headset? Thank you.

1 Like

@Hulksmash2004 try taking photos or screen recording by using the meta-quest camera tool. You can access this by clicking the meta button on your right controller (the button right below the joystick) and hovering your pointer over the video or picture icon that appears on the panel that pops up.

The camera tool that is built into Arkio is only able to visualize the immersive view of Arkio because Meta doesn’t allow developers to access that information. This would be a privacy issue.

1 Like

Welcome to the community @Hulksmash2004

Since you are using a Quest 2 Meta still has some restrictions to protect the user’s privacy when recording the passthrough cameras. Meta has removed this restriction from the Quest Pro and Quest 3 so there a normal screen recording or in-headset picture would include your passthrough camera on Quest 2 you would still have to enable developer mode and connect the headset to Meta Quest Developer Hub to enable share your black and white camera feed in your recordings.

As developers, we don’t have access to your camera view (also for privacy reasons) so the Arkio photo tool is not able to include the passthrough view on your exported photos from Arkio. Also for later headsets like the Quest 3.

Hope this also helps others with questions about Quest 2 passthrough recordings!

1 Like

learned something new today :slight_smile: :bulb: